June 14, 2004

Wipeout days

The theme for this past weekend was "reinstallations" (and also squash, volleyball and sun burns, but that's not nearly as interesting).

Overall, I have been extremely satisfied with Windows XP on all my machines, and I have even got used to my wireless connections dropping the signal mysteriously and reconnecting shortly thereafter.  My living room is about sixty feet away from the base station, so it was no surprise that the signal was low.  However, a few articles I read these past weeks made me wonder if I couldn't improve things by upgrading my current version of XP.  I read that Windows XP SP2 improved significantly the wireless connectivity, so when I had a couple of hours Sunday, I decided to upgrade my laptop to this service pack.

Big mistake.

First of all, because I realized only too late that not only is this Service Pack only a tech preview (it's not officially out yet), but that it can't be uninstalled either.  Since I didn't know that, I didn't bother setting a recovery point just before the installation (shouldn't any service pack install wizard do that for me automatically?), so by the time I booted my new XP SP2 laptop and was done marveling at the cute new wireless icons they added, I realized that not only was my wireless access completely hosed, but even my connected access was no longer able to reach even my gateway.

Annoying, but well... I'll just reinstall the original XP on that laptop and move on.  Except that...  the repair disk of that laptop doesn't come with a certificate of authenticity, so I'm unable to give the installation program a serial number.  Alright, I'm gonna go old school on that one and install my own version of XP.

This part works, but suddenly the display of my laptop seems to crawl.  A quick look at the drivers informs me that XP didn't recognize the video adapter on this laptop (a GeForce 4200) and is therefore using the generic SVGA.  Mrmph.  And it doesn't stop there:  none of the other drivers (wireless, network, sound, etc...) have been detected by XP.

I decided I had wasted enough time with this and that my laptop was overdue for a brand new re-imaging.  <sigh>

Later that day, I wanted to be able to synchronize my iPod on another machine than the one I currently use.  I install the software, connect the iPod, make sure I uncheck "Let iPod manage my music", so that the new installation doesn't wipe out the existing songs on my iPod, and I let the program happily proceed.

Then I open my iPod icon and...  nothing.  It's been entirely wiped.  ARGHHHH!

Apple is usually good in all things usability, but this overlook is just unbelievable.  And the worst is that even though I am aware of this bug, I still got caught by it...  again.  This stupid software always assumes that if you install it, you have nothing on your iPod and when it tries to synchronize both parties...  well, blam.

Great way to start the week.

Posted by cedric at June 14, 2004 03:56 PM
Comments

Sounds like payback for all that diving. Next time you shouldn't leave your devices alone lest they get jealous of your meat-family.

Posted by: Anthony Eden at June 14, 2004 05:47 PM
Post a comment






Remember personal info?